Start a new topic

ROLI Connect: Install Studio Player Problem

Attempt to install ROLI Studio Player results in message: Unable to start ROLI Hardware Driver

88 people have this problem

I much appreciate the very helpful comments here, but my Win 7 laptop (32-bit) refuses to download 64-bit apps.

My Equator, Seaboard and dashboard are fine, and I hope recently purchased Touch Block will work OK too.

But it seems I will miss out on the drums and studio player, and other 64-bit, Roli offers.

I prefer hardware, but am a humble Australian muso with three LPs trying to add computer music for modern variety.

Thanks again Folks!

im having issues with studio player and studio drums, they won't open, says I need to logon roli connect, I'm logged on roli connect and can't seem to open those 2 apps in au or stand alone, running osx 10.14.6 and I can't seem to close roli driver in activity monitor to be able to delete db folders as explained earlier here, Roli please help thanks.

2 people like this

i am so thankfull for this help, I  wasnt able to install my Studio player  for like 2 weeks or smth. 

really really a big thanks!

Hi there !

Lawrance said :

Resetting the ROLI Connect database for Windows 10

First, ensure that ROLI Hardware Driver is not running as a service by launching Task Manager and heading to the Services tab. If ROLI Hardware Driver is running, do not proceed with below steps

What if you can't install and ROLI Hardware Driver is running as a service.

In the Task Manager and heading to the Services tab, right click on ROLI Hardware Driver and select  Stop.

Now, try again to install Studio Player.

1 person likes this

I am running MAC OS 10.15.1 (19B88) and am having problems installing Roli Connect. I am continuously getting the following error: 


 I have seen the issue reported above and have tried al of the various fixes, but nothing is working. Can anyone offer a solution? 

Thanks much!

I'm running windows 7 and connect installs but it goes invisible, the icon and the app is invisible but is clickable (installed on win 10 as well so I found out how it look)..  is it meant to run win7 at all - is it my graphics drivers maybe? - BTW just connected to the other win 10 laptop via teamviewer and it shows the same invisible screen - and now I'm guessing cause the graphics driver changes when you use teamview.. 

Other than that the win 10 installation laptop roli studio player just says installing - two days now.. restarted and all no change..  drums also .. no luck.. 

Also can't we choose the directory to where it installs .. 

Also - why not just give us the installation files or a way to manually download and install of of those things.. 

The vst from cypher and strobe works fine on reaper - btw great that it runs reaper - I just got the songmaker kit - and runs fine with the cable - any news on the bluetooth compatibility - other than running midiberry thing and the midiloop.. 

- and a final question/request on garageband ios - is there a way to use the + - to actually change the next instrument - also the same with the cypher vst - I'd rather use it to change to next instrument ..

Oh yeah the ios noise app doesn't run - just shows the splash screen 10-15 sec and close - sent in that into a report thing ..

Anyway. nice product, inspiring to create stuff with it - just resolve issues ..

Oh another thing happened when I updated to latest things - the controler block started flashing when I used the usb cable on my laptop and charged it from there - when not connected was fine, then after reseting the devices a few times and running ios apps it was fine .. so using and fiddling with it accidentally fixed it .. just a note about that .. 

I have tried those steps but I am unable to get it to work and now it wont let me reinstall . Even after a full uninstall and wipe of anything Roli related. I try to open the vst and you can see the included screen shot that when go to activate Roli connect opens and gives the error message seen. it was fine before 1.10 now its severely broken. 

Hi Jackin, it's likely that you're running macOS Catalina. If this is the case, please head to System Preferences -> Security, where you can grant permission for ROLI Connect to install. Once this is complete, please run the ROLI Connect installer again, which should cause an "Open" button to appear when the error next appears. Clicking "Open" will launch ROLI Connect.

"If ROLI Hardware Driver is running, do not proceed with below steps"

Ok, so my RHD is running on my Mac. I can't force quit it in Activity Monitor. Now what?

1 person likes this

Hi everyone,

I've been dealing with the same issue than all of you, Roli Studio was impossible to install, due to Hardware Driver stuff.

So, what you want to do is : delete EVERYTHING about Roli on your Mac. Everything. And reinstall Roli Connect. Then you'll be able to install Roli Dashboard, Roli Studio and Roli Drums. Don't know why, but it seems to be the only working way.

Take Care


1 person likes this

Update : Same Issue, some steps further lol 

Deleting the two db folders fixed it for me (Windows 10 Home 1903), and I'm finally able to update Studio Player, Drums, and Dashboard. 

Followed the steps for Windows 10 and am now successfully downloading RSP. Thank you!

I have had the same problem.

I can not install neither Studio drums nor studio player.

I have already tried everything you guys say on this page.

no success. please help me.

Macbook Catalina.

the RPKG files are downloaded but they won't open.

I have tried to erase them but the same thing happens then I tried to go to

 to System Preferences -> Security, where you can grant permission for ROLI Connect to install.


1 person likes this

I Have same problem . But I can't find  this folder 


how I can fixed that >>??

Thanks .

1 person likes this
Login to post a comment