LUMI supports both iOS and Android devices.


Based on our most recent testing, the following devices are compatible with the LUMI Music app.

  • iPhone X, iPhone XS, iPhone XR

  • iPhone 11

  • iPhone SE

  • iPad 7th gen, iPad Pro 3rd gen, iPad Pro 2nd gen, iPad Mini 5th gen

  • Samsung S8, S9, S10, S20

  • Samsung Tab S6

  • Google Pixel 3, Google Pixel 4

If you don’t see your device listed above, it may well still work. We’ve focused testing on recent, much-used models from Apple, Samsung, and Google. Other models and other brands are potentially compatible, but we can’t be definitive because we haven’t yet tested all devices with the most recent app features and most up-to-date Android and iOS operating systems. 

The minimum OS required for the app to run properly are below:

  • iOS 14+

  • Android 9+

*Android 9 is the minimum OS. All Android device testing is currently done with Android 10 and above, and we cannot guarantee performance on devices running Android 9 and below. We recommend running Android 10 and above and above (with the exception of Samsung S8, which performs well on Android 9).