Start a new topic

MPE-Utility script for Ableton Live

I wrote a MIDI Remote Script which automates the tedious set up process of the midi tracks for Ableton Live. Here's a short demo video:
https://youtu.be/Hg0kUVCfxo0

You'll get the Script (and instructions) from GitHub, try it out if you like!
https://github.com/juhot/MPE_Util

Some users have verified that the script works (vi-control and Ableton forums), and I use it myself. However, if you encounter any bugs, please inform me so I can fix those :) And all feedback and  suggestions are welcome. There are some ideas listed in the Readme already though.

Cheers,
-juho

3 people have this question

Thanks for the feedback and the kind words!


I added a zip "MPE_Util" to the release, no need to rename the script folder anymore :)


I updated the script a bit too, now the number of MPE channel tracks to be created can be defined with a number added after the postfix, e.g. "-creatempe8".


-juho


3 people like this

Thanks so much for this.  This is going to save me a lot of mousing around until ableton adds mpe support.


Currently the zip file unzips to MPE_Util-master.  I wasn't sure there were any coding for the original name, so I renamed the folder MPE_Util, just in case.


It took me a while to sort everything out.  The first mistake I made was assuming that I should set my Seaboard Block as input and output in the upper section of the MIDI Preferences popup.  Your video clarified this eventually, but it flew by pretty quick the first time I watched it.


Of course I had to try grouping the Ghost Midi input track with the 16 midi tracks.  I see now why I should not do that.


This works well with my Seaboard Block.  There is a Songmaker Kit mode that allows the Lightpad block to emulate the 3 sliders and the XY pad of a Seaboard Rise.  This worked correctly with your script.


Thanks again! Very nice indeed!


2 people like this

Has anyone out there seen a good tutorial regarding connecting Bitwig with Live? Not sure what that means CPU wise, but I'd love to use Equator in Bitwig for editing MIDI purposes, but have the audio go directly into Live. Not the most ideal setup, but it would make editing MPE alot easier for me..thanks.


1 person likes this

Hi there! Thanks for script, it helps a lot. I was trying to do more complex stuff using this with instrument rack. I just made a step-by-step guide on how to configure everything properly for loading multiple instances of Equator and controling presets via instrument rack: https://beyondthepiano.jlmirall.es/2019/07/30/multiple-mpe-instances-with-roli-and-ableton/


1 person likes this

i haven't tried using it lately, but when i did it often took several tries just to get the tracks to populate as designed, and then in later instantiations some tracks remained armed, some didn't, some wouldn't arm again except manually, and then sometimes i'd open that live set another day and nothing about those tracks worked so i had to start all over. since i'm desiring MPE use for live performance (i never even tried to use it for recording) i decided to cut my losses (time lost troubleshooting, etc.) and wait for reliable stability. in Bitwig MPE is a dream come true. in Ableton, not so much. 


1 person likes this

The issue that I mentioned with -EnableArmOnSelection always happens when multiple tracks are armed so it has nothing to do with your script :)


1 person likes this

Juho Hella -- THANK YOU!!!! 


This is such an awesome time saver and seems to be working great so far, without a glitch (on Live 10, MacOS). 


Ableton's slow support of MPE has been frustrating and it keeps me from using my ROLI Seaboard more often. Sorry, just had to vent a little. 


1 person likes this

I am using Ableton 10.1.6, and there is no way to select the MPE_Util as a control surface, even though it is pasted inside the MIDI scripts folder. Can anyone help?


Can I ask what issues you guys are having with the script?  It's been pretty reliable for me so far.  The record and playback clip issue I was having above was easily solved by just mapping all the relevant clips to my SoftStep foot controller.  Other than that things seem okay.

AWESOME bit of stuff! after deciphering the soundless video it worked great, but then i went into a twilight zone and it stopped working. i'm setting up my default set so that i can use more than one MPE plugin (strobe2, cypher2, omnisphere, falcon) and at first i just tried duplicating the 3 tracks - instrument track, the group, and the ghostmidi track -  to put in a different plugin but the tracks wouldn't arm together so i tried again and things got weird. mostly nothing happened after typing creatempe, then sometimes it would populate the 16 channels but they would all be different colors and not be related to the instrument track - and no ghostmidi track either. it finally worked when i placed the new midi track BEFORE the other ones. evidently there is only one ghostmidi track that serves them all and it needs to be at the end? 


anyway, this is a HUGE relief! i'm so glad i don't have to create 5D parts on Bitwig or Logic to import to Ableton. thanks!


LIVE 10, OSX sierra

Nice - Audio Damage Quanta is 10 voices so this update will help with plugins like that!

 

Hi LSZ1318,


The main reason I'm interested in using a program like Bitwig, and have Bitwig "talk to" LIve, is that editing the MPE in Bitwig is so much easier - very clear editing of Strike, Press, Glide, Slide, and Lift. Editing MPE in Ableton is definitely trickier, for me at least. But I'm also reluctant to make a complete switch over to Bitwig, and this is why I'm interested in using both programs simultaneously.

Jay,

https://www.youtube.com/watch?v=YWmcRnQPtLc

Nice little tutorial for getting audio back and forth!

i'm with Jay Cook in that a configuration like he suggests would help me. I've now given up on using MPE to its fullest extent on my current live project because this script is not reliable, and i'm not ready to adopt Bitwig because of my familiarity with Ableton - i haven't had enough free time to really learn Bigwig enough, but i sure like the way those 5D instruments play and sound, so . . . has anyone done this yet? 

Login to post a comment